Get in touch
Back
Maintenance

Application Upgrade

Completed 30 Nov at 09:00pm EST.

intelyPlatform intelyForms intelyConnect intelyAPI
Completed

Maintenance completed

Posted 30 Nov at 09:00pm EST.
Started

The intely application will be unavailable during this maintenance window.

Posted 30 Nov at 07:30pm EST.