Back
Maintenance

Server Maintenance
Completed 9 Jul at 06:30pm EDT.
intelyPlatform
intelyForms
intelyConnect
intelyAPI
Completed
Maintenance completed
Posted
9 Jul at 06:30pm EDT.

Started
The intely application will be unavailable during the maintenance window.
Posted
9 Jul at 05:00pm EDT.